Installation

Prerequisites

Java 8 or higher must be installed. We currently recommend the latest Oracle JDK 8.

64-bit packages are generated for Linux, Windows and Mac OS.

Install Manually

Download the latest Yamcs Studio release for your platform. Extract to your preferred location and launch it. When it asks you to choose a workspace, choose a new directory where you have write rights , e.g. under your home directory. Workspaces contain displays, scripts and user preferences. By default your workspace will be populated with a few sample projects. These projects contain displays that show simulated parameters as produced by a default-configured Yamcs Server.

Install from Repository

On Linux distributions you can install the open-source version of Yamcs Studio via a package repository. Configure the Yamcs repository appropriate to your distribution following the repository instructions.

RPM (RHEL, Fedora, CentOS)

Install via dnf (or yum on older distributions)

$ dnf check-update
$ sudo dnf install yamcs-studio

RPM (SLE, openSUSE)

$ sudo zypper refresh
$ sudo zypper install yamcs-studio

Troubleshooting

Most problems related to starting Yamcs Studio have to do with Java not being correctly detected, or by trying to launch Yamcs Studio with an old version of Java. Both of these issues are usually resolved by installing Oracle JDK 8.

In case that didn’t help, Try defining the -vm property in the root Yamcs Studio.ini file. Refer to the instructions available at https://wiki.eclipse.org/Eclipse.ini.